home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / media-libs / tiff-3.7.3 / tiff-3.7.3.ebuild < prev    next >
Text File  |  2005-10-20  |  842b  |  31 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/tiff-3.7.3.ebuild,v 1.4 2005/09/30 02:21:00 vapier Exp $
  4.  
  5. DESCRIPTION="Library for manipulation of TIFF (Tag Image File Format) images"
  6. HOMEPAGE="http://www.libtiff.org/"
  7. SRC_URI="ftp://ftp.remotesensing.org/pub/libtiff/${P}.tar.gz"
  8.  
  9. LICENSE="as-is"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ~ppc-macos ppc64 s390 sh sparc x86"
  12. IUSE=""
  13.  
  14. DEPEND=">=media-libs/jpeg-6b
  15.     >=sys-libs/zlib-1.1.3-r2"
  16.  
  17. src_compile() {
  18.     local myconf=""
  19.     use ppc-macos && myconf=" --disable-cxx"
  20.     econf \
  21.         --without-x \
  22.         ${myconf} \
  23.         || die "econf failed"
  24.     emake || die "emake failed"
  25. }
  26.  
  27. src_install() {
  28.     make install DESTDIR="${D}" || die "make install failed"
  29.     dodoc README TODO VERSION
  30. }
  31.